New Garmin Issue affecting ConnectStats

At the moment ConnectStats is not working properly when using the Garmin Data from the ConnectStats Servers. I’ll explain the issue, but there is a temporary work around

Workaround

UPDATE: I have a new version pending approval from Apple that will work without the work around. With version 6.2.1, if you have “all” as a source, the app will automatically go to the web site if the ConnectStats Server didn’t receive data from the Garmin Health API.

Update as of August 6th the issue with the garmin api is resolved. So no need for the work around and using all as data source should be fine.

I you are having ConnectStats not display an activity or statistics or hanging you need to

  • Select the last good activity you have in your list (does not have to be the last one but a known good one)
  • Go to Config, Profile and select “Delete Some Activities”. This will delete all the activities from the app up to the one you have selected. It will not delete anything on any server, only in the app local files.
  • Go to Config, Services, Garmin and select for Source “Garmin WebSite”
  • Close the app fully (may not be necessary, but to ensure there are nothing in the memory cache)
  • Restart the app and try to download activities again.

When thing works again, you should be able to revert source to “all”, but monitor here or on twitter for message that it’s fixed

What is the issue

Since early today, the Garmin API is sending error instead of the activities files to the ConnectStats server. As a result the app is trying to go the Garmin website directly to get the fit file. Currently Garmin Connect is not letting you download fit files (if you go to garmin connect and select “export original” you will get an error), this second error is causing ConnectStats to hang on its processing queue (my bug).

If you select Garmin WebSite as a source it will get the data of your activity without trying to get the fit file and this seems to work at the moment.

I’ll update this as the situation evolve and post on twitter as well.

8 thoughts on “New Garmin Issue affecting ConnectStats

  1. Doesn’t fix it for me. I deleted back to Wednesday but when I tried to refresh i just get the downloading wheel. So then I tried deleting to last Saturday. Same result – it just sits there with the download Whirling symbol

  2. You can also switch garmin service to website. Then delete all activities in your profile. Close and reopen the app. Download all activities again. This worked for me.

  3. I am pushing a new version that will make it work with the “all” selected. It will automatically go to the web site if the Garmin API Server is not providing the right data. Hopefully will be released soon (6.2.1)

  4. Hi, reading your comments here … and I have tried what you have recommended but no success. Shortly my problem. ConnectStats is a great tool and since I have synchronized it – I had a nice statistics from my Garmin since 2017. Now – the Endomondo will be phasing out. So I have reloaded all the history for 2015 and 2016 which I had in to Garmin (through RunGap). And I wanted to load these also to ConnectStats. I was fighting with it and at the end I have deleted all activities and try to reload all again. It did not work. It loaded 2015 and 2016 but all what has been in before and I have deleted is not coming back. Can I somehow “clean” all ConnectStats and load all again from Garmin? Please, advise. Thank you, Andrea

    • Hi, there should be a “force reload old activities” in the service menu, but you may have already tried that. if that’s the case, send me a bug report so we can look at it in more details interactively.

Leave a Reply to Brice Cancel reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.